Meine Blog-Beiträge

Node.js 13 ICU-Unterstützung und EINE STABILE Workerthreads-API-Unterstützung

Node.js 13 ICU-Unterstützung und EINE STABILE Workerthreads-API-Unterstützung


Node.js war die neueste LTS-Version mit Version 10 und 8. Diese Version gibt den Übergang von Node.js 12.x zu LTS unter dem Codenamen 'Erbium' an. Die Versionszeile 12.x wechselt nun zu "Active LTS" und bleibt bis Oktober 2020 unverändert. Dann wird er im April 2022 für den Rest seines Lebens in "Care" sein.

Die neue Version von Node.js 13 bietet eine schnellere Inbetriebnahme und bessere Standard-Stack-Limits. V8-, TLS- und llhttp-Updates und diagnosesimtatum-Bericht enthalten Aktualisierungen für die mitihm enthaltene Diagnoseberichtsfunktion, Workerthreads, N-API und mehr.

Hauptmerkmale Node.js 13

Werfen wir einen Blick auf die grundlegenden Funktionen in Node.js 13.

V8 auf V8 7.8 aktualisiert

Diese Version ist kompatibel mit der neuen Version V8 7.8. V8 Javascript Motor diese neue Version, Es bringt Leistungsanpassungen und Verbesserungen, um Node.js über laufende Entwicklungen in Sprache und Laufzeit auf dem Laufenden zu halten.

Die vollständige ICU ist standardmäßig in Node.js 13 aktiviert.

Von Node.js 13 ist full-icu jetzt standardmäßig verfügbar. Dies bedeutet, dass hunderte von lokalen Sprachen jetzt im Feld unterstützt werden. Dies wird die Entwicklung und Implementierung von Anwendungen für nicht-englische Bereitstellungen erleichtern.

Stable Worker-API

Worker Threads-API Es ist jetzt ein stabiles Feature in Node.js 12 und Node.js 13. Obwohl Node.js bereits mit einem Einzelthread-Ereigniszyklus gut funktioniert, gibt es einige Anwendungsfälle, die für bessere Ergebnisse verwendet werden können.

Neue Compiler- und Plattformunterstützung

Node.js und V8, neuer C ++ und nutzen Sie neue Compileroptimierungen und Sicherheitsverbesserungen. WeiterMit der Veröffentlichung von Node.js 13 benötigt die Codebasis nun mindestens 10 Versionen für OS X-Entwicklungstools und Version 7.2 des AIX-Betriebssystems.

Außerdem So erstellen Sie Node.js-Anwendungen Python 3 davon Fortschritte bei der Unterstützung der Eigentümersysteme Python 2 und Python 3 installiert werden immer noch in der Lage, Python 2 zu verwenden, aber Sie sollten nur in der Lage sein, mit Python 3 zu bauen.

Wenn Sie mehr über diese Version erfahren möchten, Blogbeitrag Node.js Sowie für Versionsnotizen Zur GitHub-Seite Siehe.





Diesen Artikel teilen


Kommentare (0)

Kommentar